Post Reply 
 
Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
onArcade 2.4.2 released
05-27-2015, 04:04 AM
Post: #1
Big Grin onArcade 2.4.2 released
onArcade 2.4.2 is out. This is a minor release, so there aren't huge changes, but there are several fixes and improvements that make it worth the upgrade.

Enhancements:

Mobile support
[Image: mobile_support.jpg]
onArcade now works on mobile devices. Onarcade template is now responsive, it works on big screens and on mobile or tablet screens. In case you are using some other template that isn't yet responsive you can enable "Mobile template" in admin panel, this template will be shown only on mobile devices.

HTML5 feeds and feed languages
[Image: html5_feeds.jpg]
Famobi and Softgames HTML5 feeds have been added, together with "Only mobile games" filter. Also "Language" selection has been added to game feeds. Currently only FreeGamesForYourWebsite.com feed is available in multiple languages, but more multi language feeds are to be added soon.

EU cookie message
[Image: eu_cookie_message.jpg]
EU cookie law compliance message together with privacy policy (which is required by Google) has been added. Cookie message has been disabled by default, but in case you are based in EU you should enable it in admin panel.

Fixed bugs:
  • TAR installer issues on PHP 5.5+
  • Mochi features removed
  • Settings problem with strings that look like numbers
  • URL with ordering and no page number doesn't work
  • Query string in game feed game file URL creates errors
  • Players with same score get different rank in cup results
  • Improved full screen


System requirements:
Please note that onArcade 2.4.2 is the first onArcade that requires PHP 5.0 or newer.

Demo:
Demo is available at http://www.onarcade.com/demo.php

Download:
Available in clients area http://www.onarcade.com/Clients/Login

Upgrading:
Upgrading instructions are in readme.pdf. onArcade 2.4.0 and 2.4.1 templates are almost compatible with onArcade 2.4.2, only some minor changes are necessary. Couple of new language lines have also been added, these have not yet been translated in most of the languages listed here - http://www.onarcade.com/Clients/Languages -, so English message will be used instead until translated. Please let me know if you would like to help with any of the translations.
Let me know if you have any problems or need any help with the upgrade.

Upgrade service
In case you would rather let me do the upgrade for you then you can order upgrade service using this URL - https://secure.avangate.com/order/checko...Y=1&CART=1
It costs 20 EUR (+ VAT where applicable). In case you are upgrading onArcade 2.4.0 or 2.4.1, it includes upgrading the template and any other modifications (best effort). In case you are upgrading some older onArcade version, it unfortunately isn't possible to upgrade your template or modifications, but I will upgrade your database and URL structure.

Let me know if you have any questions or problems!
Visit this user's website Find all posts by this user
Quote this message in a reply
05-28-2015, 12:36 AM
Post: #2
RE: onArcade 2.4.2 released
Is it consistent with subtitles the file arabic ?
What are the changes in the templates?

Visit this user's website Find all posts by this user
Quote this message in a reply
05-28-2015, 01:24 AM
Post: #3
RE: onArcade 2.4.2 released
(05-28-2015 12:36 AM)r7eq Wrote:  Is it consistent with subtitles the file arabic ?
What are the changes in the templates?

All the template and language changes are in 2.4.1_to_2.4.2.txt. You can download Arabic translation from here - http://www.onarcade.com/Clients/Languages - or if you have your own translation then new messages, that need to be added to language files, are in 2.4.1_to_2.4.2.txt. Template changes are also in the same file. I don't have right to left responsive Onarcade template just yet, but I will publish it as soon as possible.
Visit this user's website Find all posts by this user
Quote this message in a reply
05-28-2015, 01:42 AM
Post: #4
RE: onArcade 2.4.2 released
Thnx Hans
Great job

Find all posts by this user
Quote this message in a reply
05-28-2015, 01:43 AM (This post was last modified: 05-28-2015 01:58 AM by wed-alqlop.)
Post: #5
RE: onArcade 2.4.2 released
Hello Hans
It seems to me Has no changes
template mobile this we need good job but
It seems that you do not have new ideas Hans
I have some ideas
=====================
remov the Related files And CHANGE Make Previous Game & Next Game From id category not From id next file
Make new file list in Nivo Slider Automatic
======================
so Hans If I want the template mobile Only What is it I need to add in 2.4.1

http://www.wed-alqlop.com/
Visit this user's website Find all posts by this user
Quote this message in a reply
05-28-2015, 11:35 AM (This post was last modified: 05-28-2015 11:40 AM by waleedkmail.)
Post: #6
RE: onArcade 2.4.2 released
Very Nice hans, I work on translate and RTL..

العاب جديدة اليوم
العاب بنات
العاب سيارات
العاب طبخ
Visit this user's website Find all posts by this user
Quote this message in a reply
05-28-2015, 12:11 PM
Post: #7
RE: onArcade 2.4.2 released
After 2.4.1 to 2.4.2 upgrade my website crashes.
I'm getting error that something went wrong and website and admin panel are unaccessable.

Any ideas?
Find all posts by this user
Quote this message in a reply
05-28-2015, 01:44 PM
Post: #8
RE: onArcade 2.4.2 released
(05-28-2015 12:11 PM)igor Wrote:  After 2.4.1 to 2.4.2 upgrade my website crashes.
I'm getting error that something went wrong and website and admin panel are unaccessable.

Any ideas?

Download the "log_*" file in the "temp" folder of your onarcade site, so you'll know what is really going wrong.
Find all posts by this user
Quote this message in a reply
05-28-2015, 01:47 PM
Post: #9
RE: onArcade 2.4.2 released
(05-28-2015 01:44 PM)Toad06 Wrote:  
(05-28-2015 12:11 PM)igor Wrote:  After 2.4.1 to 2.4.2 upgrade my website crashes.
I'm getting error that something went wrong and website and admin panel are unaccessable.

Any ideas?

Download the "log_*" file in the "temp" folder of your onarcade site, so you'll know what is really going wrong.

This is the error from the log:
Thu, 28 May 2015 08:21:04 +0000 2 Missing argument 3 for template::template(), called in /home/public_html/includes/config.php on line 92 and defined /home/public_html/includes/template.php 58
Find all posts by this user
Quote this message in a reply
05-28-2015, 01:58 PM (This post was last modified: 05-28-2015 02:29 PM by Toad06.)
Post: #10
RE: onArcade 2.4.2 released
What kind of update did you perform (replace files using those in the zip, or manually by editing the files to change yourself) ?

Check if you find this line in "includes/config.php" :
$template = new template($session->template, $session->language, $_SESSION['mobile']);
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: